Saturday, May 5, 2012

me-tv 1.4.x built from source on xubuntu 11.10

Q: How to run the latest me-tv on xubuntu 11.10 (64bit)?
For solution, go on reading :)

Motivation for me-tv
I'm the user of me-tv as for me it's the most comfortable solution of watching dvb-t on linux. It has simple ui showing me all the needed in one screen:
- video in the upper part as well as
- per channel schedule shown bellow.
For me it means no time wasted in menu clicking / new dialogs / ...

Motivation for latest version
vlc backend support (as opposed to xine only backend support in 1.3.x versions)

Status research
As in repos there is still 1.3.x version available and I'd like to use the latest one, let's do some research.

Q: What is the latest version?
Short A:  Currently it's 1.4.x
Long A: Based on this link: there is new maintainer (original is gone) - Frédéric Côté (frederic-cote) and he restarts development of me-tv in 1.4.x branch that seems to be merge of stable 1.3 (xine based) and 2.0.x (xine/vlc/gstreamer based). The good news here is the usage of vlc as backend. Finally! :)

hey, after writing this post, I've found that there exists me-tv development PPA:
And for the that's my choice. For those still interested in compiling from source, go on reading.

OK, let's do the job.
Installation steps of me-tv 1.4.x (working for me):
1. download latest stable tgz archive, for me it was (however link is on the main page, check for the latest one:
2. unpack it and get in dir
3. install dependencies (I installed all the dependencies listed on:

sudo apt-get install build-essential gettext debhelper autotools-dev libxml-parser-perl pkg-config devscripts libtool intltool libgnomemm-2.6-dev libgnomeuimm-2.6-dev libgtkmm-2.4-dev libgnet-dev libsqlite3-dev libvlc-dev libxine-dev libdbus-glib-1-dev libunique-dev

moreover I had to install these:
sudo apt-get install libxml++2.6-2 libxml++2.6-dev gnome-common libgstreamer-plugins-base0.10-dev libgstreamer0.10-dev

4. prepare / start compile/install
./configure --prefix=~/Desktop/apps/me-tv_1.4
make install

5. now it's time to cross fingers, try to start it:
cd ~/Desktop/apps/me-tv_1.4/bin/

got error:
2012-05-05 08:19:06: Me TV Server started
2012-05-05 08:19:06: An unhandled exception was generated
2012-05-05 08:19:06: Error: The Me TV database version does not match the Me TV server version.

OK, seems we need to cleanup configuration (as I've used on the same PC also older version):
mv ~/.me-tv/ ~/.me-tv_backup
it didn't help => as suggested here ( I did also:
mv ~/.local/share/me-tv ~/.local/share/me-tv_backup

one more try:
no error
we're done! :)

OK, now let's make sure no confusion with the older version happens:
sudo apt-get remove me-tv

There are still things to be fixed, like server auto start as well as integration with UI, however these I'd await from upstream.
For me it's worth using 1.4.x version and that my cpu doesn't need to be burning on 100% with xine any more. Cool!

No comments: